E-Switch

Problems connecting

I cannot connect

Check the following general points:

  • Did you remove the pull-tag (tab) at the battery before mounting the E-Switch(es).
  • Ensure a maximum distance of 10 metres between the telephone and E-Connect and between the sensors and E-Connect.
  • Is the E-Connect supplied with power (wires connected, switch on, fuse not broken)? Check the LED light on or inside the E-Connect.
  • Does the battery still have enough voltage? The E-Connect switches off below 10.8V. Charge the battery and try again.
  • Is Bluetooth enabled on the phone? (Android: is the pairing request accepted)?
  • Are you connected to the Internet (WiFi or 4 or 5G)?
  • Is no one else connected to this E-Connect via Bluetooth?
  • Has the E-Connect been updated recently? Then it is advisable to switch it off and on again.

If you have bought second-hand E-Switches, the QR code may still be linked to the previous owner’s account. Read here what you can do in these cases.

If all this is in order, there are also sensor-specific checkpoints:

  1. Is the battery still strong enough (3V)?
    Test the battery by separating the 2 parts and bringing them back together again. If the small LED on the largest part lights up, the battery is still good. Find out here how to replace the batteries.
  2. If the E-Connect is connected to a starter battery in a motor home, the battery will spike when the engine starts. This will cause the E-Connect to reboot itself and it may take some time before contact is restored with sensors.
  3. If necessary, switch the E-Connect off, wait a few seconds and then switch it on again.
  4. Finally, close the app completely (also in the background) and restart it.
If after all these checks the connection still fails, please send feedback to our Customer Support department via the app. We may be able to see in it exactly what is happening. We will then contact you to discuss and solve the problem.